GHSA-42xw-2xvc-qx8mHighCVSS 7.5

Denial of Service in axios

Published
May 29, 2019
Last Modified
April 14, 2023

🔗 CVE IDs covered (1)

📋 Description

Versions of axios prior to 0.18.1 are vulnerable to Denial of Service. If a request exceeds the maxContentLength property, the package prints an error but does not stop the request. This may cause high CPU usage and lead to Denial of Service.

Recommendation

Upgrade to 0.18.1 or later.

🎯 Affected products1

  • npm/axios:<= 0.18.0

🔗 References (8)