GHSA-425c-ccf3-3jrrCriticalCVSS 5.7
Critical severity vulnerability that affects slpjs
🔗 CVE IDs covered (1)
📋 Description
Validator parsing discrepancy due to string encoding
Impact
A specially crafted Bitcoin script can cause a discrepancy between the specified SLP consensus rules and the validation result of the slpjs npm package. An attacker could create a specially crafted Bitcoin script in order to cause a hard-fork from the SLP consensus.
Patches
All versions > 0.21.3 are patched.
Workarounds
Upgrade to any version >= 0.21.4.
References
The bug was located and fixed here.
For more information
If you have any questions or comments about this advisory:
- Open an issue in the slpjs repo
- Email us at [email protected]
🎯 Affected products1
- npm/slpjs:< 0.21.4
🔗 References (4)
- https://github.com/simpleledger/slpjs/security/advisories/GHSA-425c-ccf3-3jrr
- https://nvd.nist.gov/vuln/detail/CVE-2019-16762
- https://github.com/simpleledger/slpjs/commit/ac8809b42e47790a6f0205991b36f2699ed10c84#diff-fe58606994c412ba56a65141a7aa4a62L701
- https://github.com/advisories/GHSA-425c-ccf3-3jrr