GHSA-3x8r-x6xp-q4vmHighCVSS 7.5

Uncontrolled Recursion in Loofah

Published
December 13, 2022
Last Modified
November 4, 2025

🔗 CVE IDs covered (1)

📋 Description

Summary

Loofah >= 2.2.0, < 2.19.1 uses recursion for sanitizing CDATA sections, making it susceptible to stack exhaustion and raising a SystemStackError exception. This may lead to a denial of service through CPU resource consumption.

Mitigation

Upgrade to Loofah >= 2.19.1.

Users who are unable to upgrade may be able to mitigate this vulnerability by limiting the length of the strings that are sanitized.

Severity

The Loofah maintainers have evaluated this as High Severity 7.5 (CVSS3.1).

References

🎯 Affected products1

  • rubygems/loofah:>= 2.2.0, < 2.19.1

🔗 References (7)