GHSA-3wqh-h42r-x8fqHighDisclosed before NVD

Denial of Service in @hapi/content

Published
September 3, 2020
Last Modified
September 25, 2025

📋 Description

Versions of @hapi/content prior to 4.1.1 and 5.0.1 are vulnerable to Denial of Service. The Content-Encoding HTTP header parser has a vulnerability which will cause the function to throw a system error if the header contains some invalid values. Because hapi rethrows system errors (as opposed to catching expected application errors), the error is thrown all the way up the stack. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services.

Recommendation

Upgrade to version 5.0.2. Versions 4.1.1 and 5.0.1 are fixed but only available for direct download through the repository.

🎯 Affected products1

  • npm/@hapi/content:< 5.0.2

🔗 References (2)