GHSA-3rh3-wfr4-76mjMediumCVSS 6.5

Regular expression Denial of Service in multiple packages

Published
April 6, 2021
Last Modified
February 1, 2023

🔗 CVE IDs covered (1)

📋 Description

Impact

A regular expression denial of service (ReDoS) vulnerability has been discovered in multiple CKEditor 5 packages. The vulnerability allowed to abuse particular regular expressions, which could cause a significant performance drop resulting in a browser tab freeze. It affects all users using the CKEditor 5 packages listed above at version <= 26.0.0.

Patches

The problem has been recognized and patched. The fix will be available in version 27.0.0.

For more information

Email us at [email protected] if you have any questions or comments about this advisory.

Acknowledgements

The CKEditor 5 team would like to thank Yeting Li for recognizing and reporting these vulnerabilities.

🎯 Affected products8

  • npm/@ckeditor/ckeditor5-engine:<= 26.0.0
  • npm/@ckeditor/ckeditor5-font:<= 26.0.0
  • npm/@ckeditor/ckeditor5-image:<= 26.0.0
  • npm/@ckeditor/ckeditor5-list:<= 26.0.0
  • npm/@ckeditor/ckeditor5-markdown-gfm:<= 26.0.0
  • npm/@ckeditor/ckeditor5-media-embed:<= 26.0.0
  • npm/@ckeditor/ckeditor5-paste-from-office:<= 26.0.0
  • npm/@ckeditor/ckeditor5-widget:<= 26.0.0

🔗 References (12)