GHSA-3h4r-pjv6-cph9HighCVSS 7.5
RubyGems Escape sequence injection vulnerability in api response handling
🔗 CVE IDs covered (1)
📋 Description
An issue was discovered in RubyGems 2.6 and later through 3.0.2. Gem::GemcutterUtilities#with_response may output the API response to stdout as it is. Therefore, if the API side modifies the response, escape sequence injection may occur.
🎯 Affected products2
- rubygems/rubygems-update:>= 2.6.0, < 2.7.9
- rubygems/rubygems-update:>= 3.0.0, < 3.0.2
🔗 References (7)
- https://nvd.nist.gov/vuln/detail/CVE-2019-8323
- https://lists.debian.org/debian-lts-announce/2020/08/msg00027.html
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00036.html
- https://hackerone.com/reports/315081
- https://blog.rubygems.org/2019/03/05/security-advisories-2019-03.html
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rubygems-update/CVE-2019-8323.yml
- https://github.com/advisories/GHSA-3h4r-pjv6-cph9