GHSA-3gx7-xhv7-5mx3CriticalCVSS 9.8

Arbitrary Code Execution in eslint-utils

Published
August 26, 2019
Last Modified
February 12, 2025

🔗 CVE IDs covered (1)

📋 Description

Versions of eslint-utils >=1.2.0 or <1.4.1 are vulnerable to Arbitrary Code Execution. The getStaticValue does not properly sanitize user input allowing attackers to supply malicious input that executes arbitrary code during the linting process. The getStringIfConstant and getPropertyName functions are not affected.

Recommendation

Upgrade to version 1.4.1 or later.

🎯 Affected products1

  • npm/eslint-utils:>= 1.2.0, < 1.4.1

🔗 References (6)