GHSA-39wj-j3jc-858mCritical

XSS vulnerability leveraged through referrers could allow un-authorized admin access in Mautic

Published
January 19, 2021
Last Modified
February 5, 2024

🔗 CVE IDs covered (1)

📋 Description

Impact

This is a cross-site scripting vulnerability which affects every version of Mautic and could allow an attacker unauthorised administrator level access to Mautic.

This vulnerability was reported by Naveen Sunkavally at Horizon3.ai.

Patches

Upgrade to 3.2.4 or 2.16.5.

Link to patch for 2.x versions: https://github.com/mautic/mautic/compare/2.16.4...2.16.5.diff

Link to patch for 3.x versions: https://github.com/mautic/mautic/compare/3.2.2...3.2.4.diff

Workarounds

None

For more information

If you have any questions or comments about this advisory:

🎯 Affected products2

  • composer/mautic/core:>= 3.0.0, < 3.2.4
  • composer/mautic/core:>= 2.0.0, < 2.16.5

🔗 References (9)