GHSA-34r7-q49f-h37cCriticalCVSS 9.8

Incorrect Handling of Non-Boolean Comparisons During Minification in uglify-js

Published
October 24, 2017
Last Modified
April 12, 2023

🔗 CVE IDs covered (1)

📋 Description

Versions of uglify-js prior to 2.4.24 are affected by a vulnerability which may cause crafted JavaScript to have altered functionality after minification.

Recommendation

Upgrade UglifyJS to version >= 2.4.24.

🎯 Affected products2

  • npm/uglify-js:< 2.4.24
  • rubygems/uglifier:< 2.7.2

🔗 References (8)