GHSA-333g-rpr4-7hxqCriticalCVSS 9.8
rest-client Gem Contains Malicious Code
🔗 CVE IDs covered (1)
📋 Description
The rest-client gem 1.6.10 through 1.6.13 for Ruby, as distributed on RubyGems.org, included a code-execution backdoor inserted by a third party. Users of an affected version should consider downgrading to the last non-affected version of 1.6.9, or upgrading to 1.7.x. Additionally, a set of other minor gems have been partially or completely yanked and are included in this advisory. These include cron_parser, coin_base, blockchain_wallet, awesome-bot, doge-coin, capistrano-colors, bitcoin_vanity, lita_coin, coming-soon, and omniauth_amazon.
🎯 Affected products11
- rubygems/rest-client:>= 1.6.10, <= 1.6.13
- rubygems/cron_parser:>= 1.0.13, <= 1.0.14
- rubygems/cron_parser:= 0.1.4
- rubygems/coin_base:>= 0
- rubygems/blockchain_wallet:>= 0
- rubygems/awesome-bot:>= 0
- rubygems/doge-coin:>= 0
- rubygems/capistrano-colors:>= 0
- rubygems/bitcoin_vanity:>= 0
- rubygems/coming-soon:>= 0
- rubygems/omniauth_amazon:>= 0
🔗 References (11)
- https://nvd.nist.gov/vuln/detail/CVE-2019-15224
- https://github.com/rest-client/rest-client/issues/713
- https://github.com/rubygems/rubygems.org/issues/2097
- https://github.com/rubygems/rubygems.org/wiki/Gems-yanked-and-accounts-locked#19-aug-2019
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/blockchain_wallet/CVE-2019-15224.yml
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/coin_base/CVE-2019-15224.yml
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/doge-coin/CVE-2019-15224.yml
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/lita_coin/CVE-2019-15224.yml
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/omniauth_amazon/CVE-2019-15224.yml
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rest-client/CVE-2019-15224.yml
- https://github.com/advisories/GHSA-333g-rpr4-7hxq