GHSA-32hw-3pvh-vcvcMediumCVSS 6.3

XSS vulnerability on password reset page

Published
September 1, 2021
Last Modified
February 7, 2024

🔗 CVE IDs covered (1)

📋 Description

Impact

For Mautic versions prior to 3.3.4, there is an XSS vulnerability on Mautic's password reset page where a vulnerable parameter, "bundle," in the URL could allow an attacker to execute Javascript code. The attacker would be required to convince or trick the target into clicking a password reset URL with the vulnerable parameter utilized.

Patches

Upgrade to 3.3.4 or 4.0.0

Workarounds

No

References

https://github.com/mautic/mautic/releases/tag/3.3.4 https://github.com/mautic/mautic/releases/tag/4.0.0

For more information

If you have any questions or comments about this advisory:

🎯 Affected products2

  • composer/mautic/core:< 3.3.4
  • composer/mautic/core:>= 4.0.0-alpha1, < 4.0.0

🔗 References (5)