GHSA-2w5v-x29g-jw7jMediumCVSS 7.7
Hashicorp Nomad Incorrect Authorization vulnerability
🔗 CVE IDs covered (1)
📋 Description
Nomad Community and Nomad Enterprise ("Nomad") volume specification is vulnerable to arbitrary cross-namespace volume creation through unauthorized Container Storage Interface (CSI) volume writes. This vulnerability, identified as CVE-2024-10975, is fixed in Nomad Community Edition 1.9.2 and Nomad Enterprise 1.9.2, 1.8.7, and 1.7.15.
🎯 Affected products1
- go/github.com/hashicorp/nomad:<= 1.9.1
🔗 References (4)
- https://nvd.nist.gov/vuln/detail/CVE-2024-10975
- https://discuss.hashicorp.com/t/hcsec-2024-27-nomad-vulnerable-to-cross-namespace-volume-creation-abusing-csi-write-permission
- https://github.com/hashicorp/nomad/commit/30849c518e16647a4f698e5f5cc82bef2bf40e4d
- https://github.com/advisories/GHSA-2w5v-x29g-jw7j