GHSA-2rr5-8q37-2w7hHighCVSS 7.5

Improper Restriction of XML External Entity Reference (XXE) in Nokogiri on JRuby

Published
September 27, 2021
Last Modified
May 4, 2023

🔗 CVE IDs covered (1)

📋 Description

Severity

The Nokogiri maintainers have evaluated this as High Severity 7.5 (CVSS3.0) for JRuby users. (This security advisory does not apply to CRuby users.)

Impact

In Nokogiri v1.12.4 and earlier, on JRuby only, the SAX parser resolves external entities by default.

Users of Nokogiri on JRuby who parse untrusted documents using any of these classes are affected:

  • Nokogiri::XML::SAX::Parser
  • Nokogiri::HTML4::SAX::Parser or its alias Nokogiri::HTML::SAX::Parser
  • Nokogiri::XML::SAX::PushParser
  • Nokogiri::HTML4::SAX::PushParser or its alias Nokogiri::HTML::SAX::PushParser

Mitigation

JRuby users should upgrade to Nokogiri v1.12.5 or later. There are no workarounds available for v1.12.4 or earlier.

CRuby users are not affected.

🎯 Affected products1

  • rubygems/nokogiri:<= 1.12.4

🔗 References (5)