GHSA-2rm7-xxx8-35jhMediumCVSS 6.1
MediaWiki Cross-site Scripting (XSS)
🔗 CVE IDs covered (1)
📋 Description
Wikimedia MediaWiki 1.30.0 through 1.32.1 has XSS. Loading user JavaScript from a non-existent account allows anyone to create the account, and perform XSS on users loading that script. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
🎯 Affected products3
- composer/mediawiki/core:>= 1.27.0, < 1.27.6
- composer/mediawiki/core:>= 1.30.0, < 1.30.2
- composer/mediawiki/core:>= 1.31.0, < 1.31.2
🔗 References (7)
- https://nvd.nist.gov/vuln/detail/CVE-2019-12471
- https://lists.wikimedia.org/pipermail/wikitech-l/2019-June/092152.html
- https://phabricator.wikimedia.org/T207603
- https://seclists.org/bugtraq/2019/Jun/12
- https://www.debian.org/security/2019/dsa-4460
- https://github.com/FriendsOfPHP/security-advisories/blob/master/mediawiki/core/CVE-2019-12471.yaml
- https://github.com/advisories/GHSA-2rm7-xxx8-35jh