GHSA-2r2v-q399-qq93MediumCVSS 6.5
Request injection in Spring Cloud Gateway
🔗 CVE IDs covered (1)
📋 Description
Applications using Spring Cloud Gateway are vulnerable to specifically crafted requests that could make an extra request on downstream services. Users of affected versions should apply the following mitigation: 3.0.x users should upgrade to 3.0.5+, 2.2.x users should upgrade to 2.2.10.RELEASE or newer.
🎯 Affected products2
- maven/org.springframework.cloud:spring-cloud-gateway:>= 3.0.0, < 3.0.5
- maven/org.springframework.cloud:spring-cloud-gateway:>= 2.2.0, <= 2.2.10.RELEASE