GHSA-2p6p-9rc9-62j9CriticalCVSS 9.8
Craft CMS has potential RCE when PHP `register_argc_argv` config setting is enabled
🔗 CVE IDs covered (1)
📋 Description
Impact
You are affected if your php.ini configuration has register_argc_argv enabled.
Patches
Update to 3.9.14, 4.13.2, or 5.5.2.
Workarounds
If you can't upgrade yet, and register_argc_argv is enabled, you can disable it to mitigate the issue.
🎯 Affected products3
- composer/craftcms/cms:>= 5.0.0-RC1, < 5.5.2
- composer/craftcms/cms:>= 4.0.0-RC1, < 4.13.2
- composer/craftcms/cms:>= 3.0.0, < 3.9.14
🔗 References (6)
- https://github.com/craftcms/cms/security/advisories/GHSA-2p6p-9rc9-62j9
- https://github.com/craftcms/cms/commit/82e893fb794d30563da296bca31379c0df0079b3
- https://nvd.nist.gov/vuln/detail/CVE-2024-56145
- https://github.com/Chocapikk/CVE-2024-56145
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2024-56145
- https://github.com/advisories/GHSA-2p6p-9rc9-62j9