GHSA-2m39-62fm-q8r3HighCVSS 7.5
Regular Expression Denial of Service in sshpk
🔗 CVE IDs covered (1)
📋 Description
Versions of sshpk before 1.13.2 or 1.14.1 are vulnerable to regular expression denial of service when parsing crafted invalid public keys.
Recommendation
Update to version 1.13.2, 1.14.1 or later.
🎯 Affected products1
- npm/sshpk:< 1.13.2
🔗 References (6)
- https://nvd.nist.gov/vuln/detail/CVE-2018-3737
- https://hackerone.com/reports/319593
- https://github.com/advisories/GHSA-2m39-62fm-q8r3
- https://www.npmjs.com/advisories/606
- https://github.com/joyent/node-sshpk/commit/46065d38a5e6d1bccf86d3efb2fb83c14e3f9957
- https://github.com/joyent/node-sshpk/blob/v1.13.1/lib/formats/ssh.js#L17