GHSA-2gw2-8q9w-cw8pHighCVSS 7.8
Ruby-ffi has a DLL loading issue
🔗 CVE IDs covered (1)
📋 Description
ruby-ffi version 1.9.23 and earlier has a DLL loading issue which can be hijacked on Windows OS, when a Symbol is used as DLL name instead of a String This vulnerability appears to have been fixed in v1.9.24 and later.
🎯 Affected products1
- rubygems/ffi:< 1.9.24
🔗 References (6)
- https://nvd.nist.gov/vuln/detail/CVE-2018-1000201
- https://github.com/ffi/ffi/commit/09e0c6076466b4383da7fa4e13f714311109945a
- https://github.com/ffi/ffi/commit/e0fe486df0e117ed67b0282b6ada04b7214ca05c
- https://github.com/ffi/ffi/releases/tag/1.9.24
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/ffi/CVE-2018-1000201.yml
- https://github.com/advisories/GHSA-2gw2-8q9w-cw8p