GHSA-273r-v888-vgc6MediumCVSS 6.1

Magento Cross-site Scripting (XSS)

Published
May 24, 2022
Last Modified
February 12, 2024

🔗 CVE IDs covered (1)

📋 Description

A mitigation bypass to prevent cross-site scripting (XSS) exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. Successful exploitation of this vulnerability would result in an attacker being able to bypass the escapeURL() function and execute a malicious XSS payload.

As per the Magento Release 2.3.3, if you have already implemented the pre-release version of this patch (2.3.2-p1), it is highly recommended to promptly upgrade to 2.3.2-p2.

🎯 Affected products2

  • composer/magento/community-edition:>= 2.2.0, < 2.2.10
  • composer/magento/community-edition:>= 2.3.0, < 2.3.2-p2

🔗 References (6)