GHSA-228g-948r-83gxMediumCVSS 6.1

Improper neutralization of data URIs may allow XSS in Loofah

Published
December 13, 2022
Last Modified
November 4, 2025

🔗 CVE IDs covered (1)

📋 Description

Summary

Loofah >= 2.1.0, < 2.19.1 is vulnerable to cross-site scripting via the image/svg+xml media type in data URIs.

Mitigation

Upgrade to Loofah >= 2.19.1.

Severity

The Loofah maintainers have evaluated this as Medium Severity 6.1.

References

Credit

This vulnerability was responsibly reported by Maciej Piechota (@haqpl).

🎯 Affected products1

  • rubygems/loofah:>= 2.1.0, < 2.19.1

🔗 References (10)